FIXED: UHE on "new Solution – wizard"

Jungle Ide Home Forums Historic logs Fixed Bugs log FIXED: UHE on "new Solution – wizard"

Tagged: 

This topic contains 3 replies, has 2 voices, and was last updated by  Ziggy 4 years, 7 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #5743

    Annika
    Participant

    hey Ziggy, something is wrong here,
    when start jungle IDE and then try to make File->New Solution, then the new solution wizard comes up as expected, but when i then click the “next” button i get an UHE, wich is the following:

    Generated by user:Annika
    Object reference not set to an instance of an object.
    Running Jungle Ide version 14.07.10-A
       at Jungle.TemplatesAPI.AppendModuleSolutionTemplatesToNode(SuperTreeNode node) in C:\Users\Manel\Documents\Visual Studio 2010\Projects\JungleIde\JungleIDE\Solutions\TemplatesAPI.Monkey:line 41
       at Jungle.SelectTemplatePage..ctor() in C:\Users\Manel\Documents\Visual Studio 2010\Projects\JungleIde\JungleIDE\Solutions\Wizard\SelectTemplatePage.Monkey:line 19
       at Jungle.FirstPage.NextPage() in C:\Users\Manel\Documents\Visual Studio 2010\Projects\JungleIde\JungleIDE\Solutions\Wizard\FirstPage.Monkey:line 9
       at Jungle.WizBrowser.Button1_Click(Object sender, EventArgs e) in C:\Users\Manel\Documents\Visual Studio 2010\Projects\JungleIde\JungleIDE\Solutions\Wizard\WizBrowser.Monkey:line 32
       at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
       at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
       at System.Windows.Forms.Control.WndProc(Message& m)
       at System.Windows.Forms.ButtonBase.WndProc(Message& m)
       at System.Windows.Forms.Button.WndProc(Message& m)
       at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
    mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
    JungleIde, Version=11.3.25.0, Culture=neutral, PublicKeyToken=08450e728b1592a9
    LemonBytes.JungleAssembler, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a
    System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
    System.Core, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
    System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
    System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a
    System.Runtime.Remoting, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089

    i can reproduce this whenever i try to make a new solution.
    any ideas? :O

    #5744

    Ziggy
    Keymaster

    Does it happen with all available solution templates? Are you using the stable version of Jungle IDE or current BETA?

    #5745

    Annika
    Participant

    i used the last stable when i had this error, i was not even able to come to the menu where i can chose between the templates.
    well for any reason it is working now, ill let you know if i expect this again

    #5747

    Ziggy
    Keymaster

    Found it! i did managed to replicate it when the internal Monkey database was not built when the new solution templates dialog was requested. It’ll be fixed for the next release, but if you have this problem again, just create a temporal empty document and it should auto-fix itself.

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘FIXED: UHE on "new Solution – wizard"’ is closed to new replies.